Forum Datenbank Problem?

Dieses Thema im Forum "Fragen und Hinweise der Benutzer zum Forum" wurde erstellt von frank dux, 26. Nov. 2015.

  1. Tablet ist ein LG G-Pad 8.3 mit Android 4.4.2. Handy ist HTC One M8 mit Android 5.0.1
    Und bei mir löst auch das "+" am Ende den Absturz aus.
     
  2. Neue FRAGE anders PROBLEM

    Hallo "Pyro",
    hey "Inflammable",
    werte Gemeinde,

    entschuldigt bitte aber ich hänge mich mal mit meiner Frage an "frank dux" Thread dran.

    Wenn ich in meinem Text, im Kommentar-Feld, folgende Zeichen Reihenfolge eingebe <, wird der dahinterfolgende Text nach dem Upload scheinbar abgeschnitten.
    Ich löse dieses bislang mit einem Leerzeichen zwischen öffnender Spitzklammer und Komma.
    Falle aber oftmals auf's Neue darauf rein.

    Wollte ich nur kurz weiter geben, kann aber ganz gut mit dem Leerzeichen lauch eben.

    Liebe Grüße
    "Pyro Mäcces"
     
  3. Vermutlich wird Dein < als Beginn eines Scriptes gesehen und damit der Inhalt entfernt.
    Kommt das < bei Dir häufiger vor?
     
  4. Guten Abend "Pyro",

    so weit ich mich recht erinnere, ja!
    Aber alleine die öffnende Spitzklammer ist es nicht, immer nur in Verbindung mit dem direkt darauf folgenden Komma.
    Alleine die Eingabe ins Text Feld ergibt keine Probleme, erst nach dem Absenden der Bewertung.
    Ich kann dann den Text zum Bearbeiten zwar nochmals aufrufen, aber so wirklich richtig funktioniert ein Editieren dann nicht.
    Desshalb löche ich die Bewertung komplett und beginne auf neue nun mit zusätzlichem Leerzeichen zwischen den zwei Problem Character.

    Gruß
    "Pyro Mäcces"
     
  5. Keiner vom Forums / Datenbank - Team eine Idee was da los ist? Und noch wichtiger ob die Merkliste noch zu retten ist oder nicht. In meiner Übersicht wird sie noch angezeigt.

    Grüße Patrick
     
  6. Ich sehe Deine Meldung gerade erst.
    Mmmmh, ich kann später/morgen mal in die mySQL schauen, aber so ein Fehler ist mir nicht bekannt bzw ich kann mir nicht vorstellen, was da los sein soll.

    Ggf enthält sie einen Artikel, der nach Merken vom DB-Team geändert, gelöscht, versteckt wurde und deshalb hat die Liste ein Problem. Reine Mutmaßung.
    Wieviele Artikel enthält und welcher Natur (aktuell, Raritäten...) sind die Artikel in der Liste?
     
    original.fan gefällt das.
  7. Guten Morgen Pyro,
    Wäre super wenn du nachher mal schauen könntest.

    62 Artikel sind glaube ich in der Merkliste gespeichert. Alles relativ aktuelle Sachen. Aber Diamond Bombenrohre wären zum Beispiel auch noch mit drin.

    Grüße Patrick
     
  8. @Pyro

    Schon mal Zeit gehabt nach dem Problem zu schauen?

    Grüße Patrick
     
  9. Also...
    Deine Liste mit 62 Artikeln ist grundsätzlich noch da. Ich habe sie in der mySQL-Datenbank heraussuchen können:

    upload_2020-6-13_15-23-14.png

    Ich kann die Liste aber selbst nicht in der GUI einsehen, weil Du sie auf privat gestellt hast.
    Anhand der Artikel in der Liste oder der Liste selbst erkenne ich nicht, was haken könnte.

    Was passiert denn, was heißt "kann ich nicht öffnen"? 500er Internal Error?
     
  10. @Pyro

    Ich rufe mein Problem nochmal in Erinnerung.

    Schönen Sonntag wünsche ich!

    Grüße Patrick
     
  11. So einfach ist das nicht.

    Ich habe gestern volle zwei Stunden darin investiert und sogar eine Antwort hier im Thema geschrieben. Dann aber wieder gelöscht, weil ich nicht auf das Thema aufmerksam machen wollte, weil ich Deine Liste auf "nicht-privat" stellen musste. Ich habe den Beitrag gerade wieder "als Beweis" hergestellt.

    Kurz: alles noch als Daten in der mySQL da, aber den 500er Error konnte ich bisher in keinen Logs entdecken. Ich weiß also noch nicht, an welchem Artikel es liegt...
     
    original.fan gefällt das.
  12. Danke für deine Mühe. Auch wenn deine Ausführungen für mich wie böhmische Dörfer klingen. Bin bei Computern nicht so die Leuchte... Dafür gibt es ja auf Arbeit dann auch die IT Abteilung. ;-)
     
  13. Lösche mal die Einträge mit dem "NULL" als Eintrag
    oder schreib mal einen Inhalt wie z.B. "1" rein.
    Das war zumindest bei mir auf Arbeit mal ein Fehler.

    Beim Auslesen gab es dann in als Zahlwert definierten
    Feldern ein Problem mit genau diesen Einträgen.

    Nur eine Möglichkeit.
     
  14. Das NULL an der Stelle ist zulässig. Aber trotzdem danke.
    Ich vermute, dass ein Artikel nachträglich vom Team gelöscht oder verschoben wurde. Mangels Fehlern in verschiedenen Logs entdecke ich den aber nicht.

    Ich werde heute eine kleine Abfrage über die 62 Artikel basteln, um mehr zu erfahren...
     
  15. Passende Logs gefunden und ja, es war ein vom Datenbank-Team gelöschter Artikel, die 12369.
    Keine Anhung, was das war. Und ja, dort wird eine Exception nicht abgefangen.
     
    original.fan und Mathau gefällt das.
  16. Vielen Dank für die Problemlösung! Artikel dürfe von Evolution der Hamlet Verbund gewesen sein. Jetzt mit dem Wissen im Nachgang kann ich mich auch wieder dunkel daran erinnern, dass der Verbund dann auf einmal doppelt in der Datenbank angelegt war.

    Grüße Patrick
     
    Pyro gefällt das.
  17. Der Fehler wurde mittlerweile von unserem Supercoder der Datenbank behoben. Es betraf noch eine weitere Merkliste und sollte zukünftig nicht mehr auftreten.
    Insofern habe ich für die Fehlermeldung zu danken :)
     
    challenger, Mathau und original.fan gefällt das.
  18. #44 Westharzer, 6. Jan. 2021
    Zuletzt bearbeitet: 6. Jan. 2021
    Missbrauche mal den Thread.
    Folgendes Problem, jedes mal wenn ich in der Datenbank ein Bild hochlade, ist es nach dem einreichen auf der Artikelseite verdreht. Wie kann man das ändern?
     
    [email protected] gefällt das.
  19. Es einfach verdreht hochladen?
     
  20. Funktioniert leider auch nicht.
     
  21. Ich hatte das auch 1x bisher allerdings in einem anderen Forum wo ich die Bilder mit Abload.de bereitgestellt habe.
    Da wurde das Bild in Abload "richtig rum" angezeigt und ich wollte es um 90° gedreht einbetten. Den speziell dafür bereitgestellten HTML Code hab ich genommen aber dann war es eingebettet wieder verdreht. Ende vom Lied war das ich nur durch probieren den Code fand der im Forum das Bild "richtig rum" anzeigte.
    Daher erste Frage, nutzt du eine solche Seite um die Bilder hochzuladen?

    Grüße
     
  22. Nein lade ganz normal lokal vom PC hoch.
     
  23. Stimmt, geht in der DB entgegen dem Forum ja auch gar nicht das man da Codes einbettet.

    Es muss was mit der Aufnahme an sich zu tun haben. Wenn du zB mit dem IPhone Bilder in Querformat aufnimmst und andere in Hochkant werden dir in einigen Bildbearbeitungsprogrammen alle in "quer" angezeigt. Tatsächlich müsste man sie aber entsprechend drehen.

    Nimm doch mal besagtes Bild, öffne es in einem Bearbeitungsprogramm (ich nutze IrfanView), ändere dort die Größe auf eine zulässige Größe für die DB und ein Format das es entsprechend wie gewünscht Hoch- oder Querformat ist (zB 1920x1080 oder 1080x1920) und speichere das Bild unter neuem Namen neu ab.
     
  24. Im Querformat aufgenommen, werden die Bilder nicht verdreht.:good:
     
  1. Wir verwenden Cookies, um die technisch notwendigen Funktionen der Forum-Software zur Verfügung zu stellen und registrierte Benutzer angemeldet zu halten. Wir verwenden dagegen keine Cookies zu Statistik- oder Marketingzwecken. So analysieren wir weder die Seitennutzung noch das Suchverhalten der Benutzer und bieten auch keine personalisierte Werbung an. Wenn du dich weiterhin auf dieser Website aufhältst, akzeptierst du den Einsatz der essenziellen Cookies, ohne die das Forum technisch nicht richtig funktioniert.
    Als angemeldeter Benutzer kannst du diesen Hinweis dauerhaft ausblenden.
    Information ausblenden