Handhabung & Technik RaspEasyFire - RaspberryPi Funkmodul für El Fueradoro Zündanlage

Dieses Thema im Forum "Effekte, Feuerwerkskörper, Technik, Hilfsmittel" wurde erstellt von Newan, 4. Aug. 2018.

  1. #701 Legospieler, 7. März 2021
    Zuletzt bearbeitet: 7. März 2021
    Hallo zusammen,

    nachdem mein Display gestern gekommen ist, wollte ich mal versuchen das Image zu installieren.

    Mir fehlt derzeit noch das RFM69HCW

    Folgende Setup habe ich getestet:
    Aktuelles Image 20210120
    Raspberry Pi 3B v1.2
    Display nur HDMI und HDMI+USB
    Mit und ohne Aufsteckplatine.

    Beim ersten Start bleibt er hier stehen:
    B1B1DEF6-E9FF-4EC6-AEC2-8BBE4A661793.jpeg

    Wenn ich den Stecker ziehe und Neustarte, hab ich die Möglichkeit den FireButton zu drücken, danach bleibt er hier stehen:

    F60297E3-8E3B-4FF0-97A2-609668167EE2.jpeg

    Theoretisch müsste es doch auch ohne RFM Modul gehen, da ja beim Tausch vom CW auf das HCW, dieses abgezogen werden soll und Raspeasyfire ohne Modul gestartet wird.

    Liege ich hier falsch?

    Hätte mir jemand ein älteres Image?

    Grüße LegoSpieler
     
  2. Beim ersten Start sollte an der gezeigten Stelle eigentlich die Nachfrage kommen, in welcher Auflösung man den raspEasyFire betreiben will (ON-OFF-Button für 1024x600, FIRE für 800x480) und mit welchem Funkmodul (ON-OFF-Button für CW, FIRE-Button für HCW). Interessanterweise wird dieser Text auf manchen Displays einmal, auf manchen zweimal und auf manchen gar nicht angezeigt. Leuchten bei dir denn an irgendeiner Stelle beim ersten Boot die beiden Button-LEDs bzw. leuchten LEDs, wenn du welche an der dafür vorgesehenen Stelle der Aufsteckplatine anklemmst?
    upload_2021-3-7_11-35-0.png

    Ansonsten ist es schwer zu beurteilen, wo das Problem liegen könnte, denn echte Fehlermeldungen sehe ich leider keine.
     
  3. Hab jetzt mal kurz LEDs drauf gebruzelt, und die Karte neu beschrieben:

    beide LEDs leuchten, hab dann den ON/OFF Button gedrückt, dann ging es weiter.

    Nach dem reboot und Fire Button für den Start gedrückt, bleibt es an der gleichen Stelle stehen.
    Grüne LED leuchtet.
     
  4. A6DA4004-050D-4101-BB22-05C6EFDBBDE9.jpeg
    nach einiger Zeit hab ich nochmal den OnOff Button gedrückt
     
  5. Ok, wenn ich mein Funkmodul ziehe, dann laufe ich in dasselbe Szenario. Der Fehler rührte noch von der Suche nach der "verlorenen" Zeit anlässlich der 100-ms-Thematik her. Damals hatte ich meine "wait_for"-Funktion im Verdacht und habe sie - inklusive Timeout bei fehlender Antwort - auskommentiert und eine while-Schleife eingebaut, die ohne Modul zur Endlosschleife wurde. Fehler ist im Repository gefixt. Wenn deine Kiste WLAN-Zugang hat, kannst du auf dem raspEasyFire im Ordner /home/pi/raspEasyFire3/script das Script ./ref_upgrade.sh aufrufen:

    upload_2021-3-7_17-27-13.png

    Neues Image, das diesen Stand automatisch enthält, ist in der Mache.
     
    Legospieler gefällt das.
  6. Es geht! Es geht!

    Super vielen Dank!
     
    zuendlER84 gefällt das.
  7. Hi
    jetzt war ich dann doch schon recht weit :)
    Heit dann alles vom losen Aufbau in die Box verbaut und siehe da folgender Fehler:
    IMG_20210402_164449_edit_7954924617535.jpg

    Ich habe mehrere Slave Suchen gemacht, 1 mal wurde auch einer gefunden. Eine Suche später wieder nicht mehr.
    RFM und Raspi Modul getauscht (hatte es doppelt gebaut), neuer Versuch aber gleiches Resultat.

    Ideen oder Vorschläge? An welchen Werten sollte man drehen ? :)

    Viele Grüße
     
  8. Squelch-Warnung heißt, dass die eingestellte Schwelle für die Triggerung des Empfängers (vermutlich -100 dBm) für deine Umgebung zu empfindlich gewählt ist. Auf diese Weise wird der Empfänger im raspEasyFire permanent durch Rauschen getriggert und ist für die eigentlichen Signale taub. Du musst in den Einstellungen den Schwellwert erhöhen, bis der Fehler bei der Slavesuche nicht mehr auftritt. Zum Testen dürften -80 dBm ausreichen, später im Feld kann man immer noch feintunen.
     
  9. Hi, vielen Dank für die schnelle Antwort, ich werde es morgen mal probieren
     
  10. Hi, hat funktioniert. VG
     
  11. Hey ich habe Probleme die aktuelle Firmware zu Downloaden unter dem Link https://raspeasyfire.de/raspEasyFire.img startet der Download nicht auch nicht im neuen Fenster egal ob Internet Explorer oder Chrome.

    Was könnte ich tun?

    LG
     
  12. Bei mir geht es im neuen Fenster.
     
  13. Da das per Link bei mir einfach nicht funktioniert hat, habe ich es mit dem Programm JDownloader2 geschafft den Link herunterzuladen, einfach bei chip.de die Software JDownloader Herunterladen damit geht das wunderbar.

    LG
     

  14. Chrome:
    rechts-click auf den Link > "speichern als" > download gestartet
     
    Pyrophil gefällt das.
  15. Wenn ich auf den Link klicke kommt eine Umleitung und nach ca. 3s geht ein Fenster auf und fragt wohin speichern. Ich benutze Firefox...

    Gruß

    Tobias
     
    Pyrophil gefällt das.
  16. #716 zuendlER84, 13. Apr. 2021
    Zuletzt bearbeitet: 13. Apr. 2021
    Seitdem im Januar die besonderen Eigenheiten hinsichtlich der Sendedauer klar geworden sind, habe ich getreu dem Motto "Turning weaknesses into strengths" den schon öfter geäußerten Wunsch aufgegriffen, mehrere verschiedene Slave-Kanal-Kombinationen gleichzeitig schießen zu können. Hintergedanke: Wenn sowieso 16 Bytes an Payload verschickt werden, von denen ein normaler Zündbefehl nur vier benötigt, kann man die restlichen zwölf auch sinnvoll nutzen. Auf den Boxen war es relativ schnell umzusetzen, beim raspEasyFire hinsichtlich ZPL-Import und -Überprüfung aber ein ziemlicher Eingriff ins bestehende System. Inzwischen ist aber alles prinzipiell lauffähig und man hat nun die Möglichkeit bis zu sieben Cues gleichzeitig auszulösen.

    Text gelöscht, da deutlich besserer Vorschlag fürs Handling kam!

    Update ist für Boxen und raspEasyFire nötig.
     
  17. Hallo Felix, in der V2.0 von PyroIgnitionControl ist es doch deutlich mehr. Hier stehen bereits 199 Slave IDs zur Verfügung.
    Ich kann hier doch Zeitgleich z.B. Slave 1 - Kanal 1 und Slave 3 - Kanal 7 Speichern. Es bringt mir auch keine Fehler beim Speichern der ZPL. Leider kann Ich es jedoch nicht testen da ich derzeit keine Anlage zum testen habe.

    Oder habe Ich das mit den sieben Zündung falsch verstanden ?

    upload_2021-4-13_17-10-26.png
     
  18. PyroIgnitionControl ist in Version 2.0 maximal verwirrend, was die Bezeichnungen angeht. Im Programm heißt die Variable Channel, die in der zpl-Datei Slave heißt und um den Wahnsinn komplett zu machen, wird Output in der zpl zu Channel.

    Für El Fueradoro ist Channel die Slave-ID und Output der Kanal, weil die Ordnung von groß nach klein gehen sollte. Und bei mir meckert das Programm, wenn ich auf den Cue klicke und "Channel", also die Slave-ID, größer als 99 einstellen will.
     
  19. Also ich habe die V2.0 auf deutsch bei mir auf dem Rechner, und Ich konnte zu Silvester meine ZPL ganz normal abspeichern und die Show starten. Ich hatte bisher mit dieser Version keine Probleme
     
  20. Hallo @zuendlER84, wäre es nicht möglich, einfach in PyroIgnitionControl die verschiedenen Zündungen mit gleicher Zeit anzugeben? Die werden dann als eigener Eintrag angelegt. Die SW müsste dann prüfen ob es noch eine weitere Zeile mit identischer Zeit gibt.
    Oder wird der Zündplan Zeile für Zeile abgearbeitet? Wenn das der Fall ist könnte es vielleicht helfen zusätzlich ein "[x]" (mit x=Anzahl der gleichzeitigen Zündungen) in der Beschreibung anzugeben. Dann weiß die SW wie viele Zeilen dazu gehören.
     
    zuendlER84 gefällt das.
  21. Dein Screenshot zeigt aber die englische Version und dort ist es, wie jeder sehen kann, so, dass Channel die Slave-ID ist und Output der Kanal. Und "Channel" hat einen Maximalwert von 99. Dem Parser in raspEasyFire ist egal, welche Sprache verwendet wird und was PyroIgnitionControl für Bezeichnungen verwendet, der geht stumpf nach der Spaltennummer.

    Diese Idee gefällt mir sehr gut, das habe ich gleich so umgesetzt! Einfach, kompatibel mit allen PyroIgnitonControl-Versionen und erspart die ganzen Klimmzüge beim Parsen des Beschreibungstextes. Man muss nur dafür Sorge tragen, dass die Auslösezeit wirklich gleich ist, ansonsten schlägt die 100-ms-Keule zu. Und nein, ich möchte den User nicht bevormunden und einfach alle Cues zusammenziehen, die weniger als 100 ms auseinander sind.

    Ergo, neue Anleitung: Um Cues gemeinsam auszulösen, einfach für jeden Slave-Kanal-Kombi einen eigenen Cue anlegen und die Auslösezeit identisch einstellen.

    Ja, das Einlesen geschieht Zeile für Zeile. Ich muss jetzt halt einfach schauen, ob die Auslösezeit identisch zu der des vorherigen Cues ist und einen neuen Cue anlegen, falls das nicht der Fall ist, bzw. zum vorherigen Cue hinzufügen, falls die Zeiten identisch sind. Das ist sogar schon so angelegt gewesen, um die Chain-Funktion von PyroIgnitionControl 2 zu unterstützen, jetzt habe ich es noch für unterschiedliche Slave-Kanal-Kombinationen aufgebohrt.
     
    Fibricus, Pyrophil, GethPrime und 2 anderen gefällt das.
  22. Halleluja!
    Auf so ein Feature hab ich gewartet! Ein wahrer Game-Changer, neudeutsch. Das verändert meine gesamte Empfänger-Topologie in Zukunft. Und es spart mir etliche Meter an Leitung, die ich sonst zwischen den Positionen ziehe. Eigentlich wollte ich die fehlende Synchronzündung mit den neuen Minimodulen umschiffen, aber das hier ist natürlich nochmal angenehmer. Sonst hätte ich mich wohl in der Planung auf x Minimodule pro Position festgelegt und damit doch wieder eine künstliche Einschränkung gehabt.

    Danke für deinen unermüdlichen Einsatz und und die vielen tollen Weiterentwicklungen der letzten Monate!
     
    Chiricahua gefällt das.
  23. Die sind ja auch eigentlich für andere Raffinessen gedacht ;)
     
    Chiricahua gefällt das.
  24. Wie sieht es mit denen aktuell eigentlich aus? Mein letzter Stand war Start der Beta-Tester mit den aktuellen (gefixten) Modulen. Gibt es schon Erfahrungsberichte?
    Reine Neugierde :whistling:
     
  25. Auch Ich würde mich über den aktuellen Stand freuen.
     
  1. Wir verwenden Cookies, um die technisch notwendigen Funktionen der Forum-Software zur Verfügung zu stellen und registrierte Benutzer angemeldet zu halten. Wir verwenden dagegen keine Cookies zu Statistik- oder Marketingzwecken. So analysieren wir weder die Seitennutzung noch das Suchverhalten der Benutzer und bieten auch keine personalisierte Werbung an. Wenn du dich weiterhin auf dieser Website aufhältst, akzeptierst du den Einsatz der essenziellen Cookies, ohne die das Forum technisch nicht richtig funktioniert.
    Als angemeldeter Benutzer kannst du diesen Hinweis dauerhaft ausblenden.
    Information ausblenden